No Code generated in CslaExtension1.cs file

Sep 18, 2010 at 2:00 PM

Hi Guys,

I have installed the CslaExtension.vsix and tried to follow the instruction given in "CslaExtension Demo Application.doc". and CslaExtension1.cs file is generating but there is no code against entities exists in model. The cs file output is as follows:

// This is auto-generated file. Do not change manually this code.
// If you want to extend or override functionality please write
// appropriate partial methods.
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using Csla;
using Csla.Serialization;

namespace CslaExtensionDemo.Library
} // end of namespace CslaExtensionDemo.Library

Is there i am missing something?


Sep 21, 2010 at 7:39 AM


I have tried but can not reproduce this behavior. Have you solved this problem?

Did you follow steps from the video tutorial?



Sep 21, 2010 at 2:22 PM


Make sure you have set the CSLA Template property for at least one of your entities ?<

If you have not, then you would get such an "empty" generation.