Missing CslaExtension.tt?

Aug 13, 2010 at 7:36 PM

Hi,

Installed the latest vslx file and the CslaExtension.tt isn't showing up either in C# Add Generation Files in the edmx nor under general add files.

I'm working under German Windows but with an English VS 2010 version.

Could that be the problem (my standard installation path is "Programme" and not "Program Files"

How did you set up the installation? Is Programm Files hard coded?

Thanks

Ben.

Developer
Aug 13, 2010 at 9:01 PM

Hi,

Could you try this:

http://rcpt.yousendit.com/915134935/f850bb494cd8bae8e00338e95a7cd6d9

and let me know ?

Thanks

Aug 15, 2010 at 8:18 AM

Sorry,

I was offline over the weekend and your link expired.

Could you send me a new one. Thanks.

Developer
Aug 17, 2010 at 11:47 PM

Hi,

sorry for delay.

Here you go:

http://rcpt.yousendit.com/929868911/28818d6a0c20cd5cf895fc53d8f7369b

Aug 18, 2010 at 8:09 AM
Hi, No problem. I checked. It still isn't showing up. I suspect it might then be a problem with the dll. It either might have an error or simply not be trusted. I can still add the template by hand and use that.
Sep 15, 2010 at 2:38 PM

Hello,

I'm also having a problem with this. I just downloaded and installed the latest version(beta2), but I'm not able to select the CslaExtension.Template file when trying to add a code generation item. I've tried disabling and re-enabling the extension but without any luck. Please let me know if you need any other information.

Also, my internet connection at work seems to block those rcpt.yousendit.com links, so I'm not able to see any information from there.

Thanks,

Steve

Sep 15, 2010 at 3:16 PM
Edited Sep 15, 2010 at 3:25 PM

This seemed to work for me. It looks like I had to take the template files here:

C:\Documents and Settings\<Username>\Local Settings\Application Data\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7\ItemTemplates\CSharp\1033\ADONETArtifactGenerator_CslaExtension.ItemTemplate.zip

and copy it to here: C:\Documents and Settings\<Username>\My Documents\Visual Studio 2010\Templates\ItemTemplates\Visual C#

Developer
Sep 15, 2010 at 4:14 PM

shaselc,

The Yousendit links expire after a while.

I guess we should look into an updated release so that all can test the new way in which we package the dll.

Can you just tell me exactly what OS you have tested this on ? Important is to tell me what language your OS is.

Thanks

Sep 15, 2010 at 8:19 PM

I use the german version of windows.

You might consider trying something like...

        Dim path As String = Environment.GetFolderPath(Environment.SpecialFolder.MyDocuments)
        path = IO.Path.Combine(path, "Visual Studio 2010\Templates\ItemTemplates\Visual C#") 



That will give the "My Documents" folder for the current windows installation.

Hope that helps.

Ben

Developer
Sep 15, 2010 at 9:17 PM

Hi Ben,

VSIX doesn't install to the "My Documents" folder.

My feeling is that non US-EN systems are getting this problem. That's why I have redesigned the way that the template and dll are packaged for language agnostic installation, but we just haven't had time to release a new beta with this change.

There has been a change between beta 1 and beta 2 (introduced by me) in the packaging, and unfortunately it seems to cause problems for non US-EN systems.

Like I said, I just need to roll-up a new beta release, which shouldn't be too long.

Sorry for all the inconvenience.

Luc

Sep 16, 2010 at 11:36 AM

I am using Visual Studio 2010 Ultimate edition on and English version Windows XP 32-bit. Let me know if you need any other information.

Developer
Sep 16, 2010 at 1:25 PM

Shaselsc,

Is it a US english system (codepage 1033)  ?

I think this is important, as my feeling is that the path where the extension is installed contained the codepage 1033, and maybe VS will not look there if your system's default codepage is not 1033.

In any case, we now have a BETA3 version. Could you make sure you remove the old one and try this one.

Make sure you remove the template that you copied over to your "My Document" folder !!

Sep 16, 2010 at 1:29 PM

I believe it would be US-EN as that's where I'm currently located. Do I need to set something in VS to have the standard codepage to be 1033? I'll look into getting beta3 shortly and I'll make sure to delete the old template as well. Thanks for the heads up!

Developer
Sep 16, 2010 at 2:34 PM

Better not waste any time trying to configure VS.

try Beta 3, and keep me posted.

Thanks

Sep 17, 2010 at 5:32 PM

Hey Luc,

I uninstalled Beta 2, deleted the old template, and installed Beta 3. When I went to add a code generation item, I did not find the CslaExtension.Template. I even looked under the Application Data folder and didn't even find the Extensions folder at all. What can I do to fix this?

Thanks,

Steve

Developer
Sep 17, 2010 at 6:01 PM

Hi Steve,

Look under C:\Users\<UserName>\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7

You won't find the *.tt file itself, as it is packaged in a zip file (this is VSIX standard way of packaging templates)

Please confirm if there is a ADONETArtifactGenerator_CslaExtension.ItemTemplate.zip file in the ItemTemplates subfolder.

Thanks

Sep 17, 2010 at 6:14 PM
Edited Sep 17, 2010 at 6:47 PM

I can get all the way to this point: C:\Documents and Settings\<UserName>\Application Data\Microsoft\VisualStudio\10.0, but my Extensions folder seems to have disappeared entirely now.

EDIT: Disregard that. I didn't go to the Local Settings folder. I did find the CslaExtension template here: C:\Documents and Settings\<UserName>\Local Settings\Application Data\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7\ItemTemplates

Developer
Sep 17, 2010 at 7:45 PM

Ok,

So we know that the VSIX installed the file to the proper location, but still you can't see the template when you want to "Add Item..." to your project.

One silly question, is this a C# project ? The extension is only for C# projects. I mention it because one day I wanted to test the setup, and without noticing I created a VB,NET project, and I spent maybe 1.5 hours trying to figure out why I wasn't seeing the template !!!! :-)

regards

Sep 17, 2010 at 7:55 PM

All questions are fair when trying to solve software problems. :) I'm actually working on a C# project just like the demo you have on this site.

Sep 23, 2010 at 10:56 PM

I just found your project. I downloaded and installed the extension. I am experiencing the same issue as others. I see the extension in the Extension Manager, but when I add a new item, I don't see "CslaExtension.Template".

At my company, they moved the Windows system variable for  "My Document" to a network location. I have tried moving the extensions folder to several different locations on my computer, but I have not been successful yet.

I read this article from Sara Ford. She said extension packages are supposed to be in App Data.

Help please, THANKS!

Mike

 

 

Coordinator
Sep 24, 2010 at 7:12 AM

Hi Mike.

Luc is trying to solve this problem, thanks for your help. Until then, you can add CslaExtension.tt file to your project manually, just like any other file. Locate the .tt file (or download it from the source code here on codeplex) and add it to your project. After doing that, you just have to edit the path to the edmx file in your project. 

~Josip

Developer
Sep 24, 2010 at 12:28 PM

I'm really puzzled by this one.

a *.vsix file is really just a *.zip file, so one can easily inspect the content.

If you look inside the current beta and compare it to beta 1, the differences are minor, and I'd be hard pressed to find what could be causing this. The changes to the VSIX packaging were introduced shortly before beta 2, and at that time I know that the packaging was quite different than beta 1. But with beta 3, I have tried to adapt the automated VSIX packaging to be as close to the beta 1 format.

As I've said many times, I have tested the VSIX on different computers, and it just works. This means I can't reproduce the problem, so I can't bring a solution unless someone, with a "faulty" install, offers to help me.

It would of course be very productive if we could set an IRC chat room (or any other IM actually), and test different things in real time. I'd also be very interested if anyone with the problem could set things up to actually compile the source code on their machine and see if it still causes problems.

If anyone is interested, let me know and we'll see what time during the day (or night) is most convenient.

Again, I'm really sorry about the problem, but I can't put my finger on it :-(

Regards

Sep 24, 2010 at 3:07 PM
Edited Sep 24, 2010 at 5:52 PM

Thank you for the reply. A coworker was looking into this situation while I sent the email to the project. He did the actions you described by editing the .tt file to point to the model. This worked perfectly. We loose a bit of the automation, but this is still a very doable solution. It seems to me that we would manage the T4 file to be the “generator” for the  different models we create.

This is a very exciting project. Great work!

Sep 24, 2010 at 3:14 PM
Edited Sep 24, 2010 at 3:17 PM

I’m happy to help in whatever ways I can. I am not very familiar with Visual Studio’s extensions and how they are managed.

I do know that because of the corporate policies here, our “my documents” folder is technically on a secure local network. Unfortunately, the policy has the path pointing to user root folder where we do not have write permissions. You have navigate “down” one folder into your name to gain access to the true personal folders. Now this was found to be a problem with Visual Studio because the Projects & Solutions properties in the options were pointing to the readonly path and therefore couldn’t save simple things like our settings. It showed up in more complex things like the macros project not working at all. We had to change registry paths to tell Visual Studio where the correct paths are located.

One suggestion: perhaps we both agree to download for the Visual Studio gallery an extension from Microsoft and verify that works on both our systems. If we establish this baseline, then we can see how CslaExtensions is different. With all that said, perhaps you could describe some expectations you have for a system in terms of file locations and perhaps registry items.

Mike

Developer
Sep 24, 2010 at 5:32 PM

Mike,

Thanks for offering your help.

One thing I'd like to point out is that as far as I know, the template and extension dll are not installed below "My Documents", but rather below "AppData", as for example on my system:

 C:\Users\<UserName>\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\<VersionNumber>\

I don't specify the actual location of the install files in my VSIX project, so I'm assuming that the above path is the default for VS2010 extensions.

That being said, there are differences in the manifest file between beta 1 and beta 3 because we now use a Custom Wizard that lets the user select the model to which the template should be "attached". I guess one could try to manually tweak the manifest file to see if it solves the problem.

If you have time, please take a look at the beta 1 VSIX, and compare the manifest inside with the beta 3 one, and change settings one by one until it works on your system. Like I said in a previous post, I can't do it myself as I can't reproduce the problem here.

Cheers

Sep 25, 2010 at 12:16 AM

I haven't had any success so far. I have even been comparing to other vsix without success.

Dec 1, 2010 at 3:05 PM

I have the same problem.

I use windows server 2003  CN and vs2010 with the latest version 1.01 cslaextension. 

 

Coordinator
Dec 1, 2010 at 4:29 PM

Hm, we did not hear about this issue for a long time. You can use following workaround: download source code labeled "1.0.1" and inside you'll find CslaExtension.tt file. Paste file to your project, then open file and edit path to the edmx file.

If you need any help, feel free to contact me. I'll add this issue to the issue tracker again.

 

 

Coordinator
Dec 1, 2010 at 4:29 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.