Installing latest Beta

Jul 14, 2010 at 12:54 PM
I've uninstalled the previous VSIX from the extensions manager. I double clicked on the latest beta and it installed fine. I can't see any wizard anywhere and the template isn't list as an item type. Am I doing something wrong ?
Jul 14, 2010 at 1:07 PM


Just making sure, but have you restarted VS2010 after uninstalling the old version and installing the new one ?

Also, which edition of Visual Studio do you have ?

As for the wizard, it will show up only when you "Add new Item" to the project and select "CslaExtension.Template", which should show up under the C# items.

Jul 14, 2010 at 1:27 PM

Yep, restarted VS2010 after unistallling old and installing new one.

I've got VS2010 Professional

There's no "CslaExtension.Template" in the new item types list.

Jul 14, 2010 at 1:41 PM

Could you verify that you have something installed under:

C:\Users\<Your User Name>\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7

Jul 14, 2010 at 1:43 PM
Edited Jul 14, 2010 at 1:43 PM
Same thing happened to me on my desktop machine, but everything installed ok on my laptop. We'll solve this issue ASAP. I think that VS is disabling the template for some reason (maybe user rights).
Jul 14, 2010 at 1:50 PM

Please make sure that things are installed EXACTLY under this path:

C:\Users\<Your User Name>\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7

What I have seen once, and have not been able to reproduce, is that installation path was:

C:\Users\<Your User Name>\AppData\Local\Microsoft\VisualStudio\10.0Exp\Extensions\Inter-net d.o.o\CslaExtension\1.7, which would make me think that the extension was installed under the Visual Studio Experimental Hive.

Jul 14, 2010 at 2:34 PM

This is where I found things installed to:

 Directory of C:\Documents and Settings\allens\Local Settings\Application Data\M
icrosoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7\~IC\Item

What's the ~IC folder all about ?


Jul 14, 2010 at 2:42 PM

The ~IC folder, as far as I can tell, is a cache created by Visual Studio

Your path seems to be good. Like Josip mentioned, it seems that something in the machine setup is causing this, as it runs fine on one of his computers, and not on the other. On my side I have tested on 2 different systems without any problems.

Do you have the possibility to test on another computer ? We need to find out if there are commonalities between systems where it doesn't work.


Jul 14, 2010 at 2:48 PM

I'll test on my home laptop later today about 6 ish.

Jul 14, 2010 at 7:05 PM

Ok, just had a go on my laptop.

Its installed, the template (jigsaw icon) is in the add new items list.

I select it, click Add and get an Object reference not set to an instance of an  object error.

This environment is VS2010 Pro on Windows 7, my OS on the other box is Win XP Pro SP3.


Jul 14, 2010 at 7:54 PM

Can you tell me the exact step you use to insert the new item ? Which menu, on which file in the project you currently are positioned (in the solution explorer), etc... as many details as you can give.

I can't reproduce the error. I tried adding the New Item through the context menu, or through the main menu. All is good.

When you get the NullReferenceException, do you also get a stack trace ? Please include it if you do get one.

Thanks for helping us finding all the possible issues.


Jul 15, 2010 at 8:49 AM

I've found a workaround for this issue:

1. Install the extension and close VS

2. Copy file

From: C:\Users\YOUR_USER_NAME\AppData\Local\Microsoft\VisualStudio\10.0\Extensions\Inter-net d.o.o\CslaExtension\1.7\ItemTemplates\CSharp\1033\

To: C:\Users\YOUR_USER_NAME\Documents\Visual Studio 2010\Templates\ItemTemplates\Visual C#

Now you should see the template when adding a new item.


Jul 15, 2010 at 12:08 PM


Just wondering about the length of the path when the extension is installed to the %APPDATA% folder.

My user name is very short "luc". What aboout yours ? Could it be that it exceeds the maximum length ?

Or also, since the extension installs to a subfolder "1033", which is the Locale ID for english-US. Could it be that your system is set to another locale, thus not looking in this subfolder ?

Jul 15, 2010 at 12:58 PM

My locale is En-US on work pc, En-GB at home.

My user name is allens at work and Sam at home.

My steps for installing the VSIX is to double click it. It runs, identifies VS2010 and completes install. Then I start VS2010.

There is no stack track for the null object reference.

Jul 15, 2010 at 1:04 PM
Hi Xtorti0n. Does the workaround I posted work for you?
Jul 15, 2010 at 1:30 PM

Yep, that worked a bit further.

I got the wizard dialog now. I'm adding the new template in a project that has an .edmx model in it.

Sadly the wizard did not list my model to select. All I could do was cancel.

Jul 15, 2010 at 1:42 PM
Edited Jul 15, 2010 at 1:42 PM
You must build the project before adding a new item template. Sorry for the inconvenience, but we changed the VSIX setup procedure and this issue will be solved ASAP.
Jul 15, 2010 at 2:37 PM

Built the project, tried adding new template. Still empty wizard, no model listed.

Jul 15, 2010 at 2:51 PM
Edited Jul 15, 2010 at 2:51 PM
Hm, and if you try to add a new template using 'Add new code generation item...' from the EF model designer?
Jul 15, 2010 at 2:57 PM

If I do that, I get the add new item dialog filtered to code gen items. I pick the csla code gen item and it generates the

csla objects for the model.


Jul 15, 2010 at 3:56 PM

I tried changing the regional settings on my computer to something completely different (estonian) to see if I could experience the same problems, but no.

Could you guys confirm the version of windows, the language of your Windows  and the regional settings you're using ? Maybe I'm looking in the wrong direction, but I feel like this could be the source of this problem.

 By the way, there's no need to build the project before adding the new item. It works on a fresh new project (at least here :-)


Jul 16, 2010 at 9:14 AM

My work PC:  Win XP Pro SP3 en-us, VS2010 Pro.

My home PC: Win 7 Ultimate en-gb, VS2010 Pro.

Jul 16, 2010 at 9:27 AM
Edited Jul 16, 2010 at 9:29 AM

My desktop PC: Win 7 Enterprise 64 bit, regional Croatian hr-hr - same problem like Xtorti0n

My laptop: Win 7 Enterprise 32 bit, regional Croatian hr-hr - installed OK

Jul 19, 2010 at 6:34 PM

I'll try to create a new version of the VSIX that doesn't include the LCID as part of the path as this is the only difference that I can see with the previous VSIX release.

On the other hand, the Beta 2 VSIX has been download more than 60 times, with only 2 reports of this behavior so far.

I'd really like to know how it went for others.

Jul 21, 2010 at 5:04 PM

For some technical reasons, it's more difficult than I thought.

I need to delve into MSBuild in order to modify the build behavior which by default wants to include the LCID in the path where the template is stored.

I'm not giving up :-)

Jul 22, 2010 at 6:19 PM

Could you guys try this VSIX file to see if it solves the problem on your respective machines ?

Josip, if you look inside this VSIX, you will see that I got rid of all the "sub paths", and my feeling is that this was causing the problem on some machines.

Let me know.

Jul 23, 2010 at 11:10 AM

Installed ok on my work pc.

When I add a new item and pick the csla extension template to add to a project that contains an entity model,

the wizard appears for me to pick an entity model, but the list of models to pick from is empty. All I can do at

this point is cancel.

Jul 23, 2010 at 1:12 PM

Could you zip your project and send it to me ? Use my YouSendIt drop box at:

Unless your project structure is "special", it should pick up all the *.edmx files in it. Did you change the file extension of your model ?

Also, please note that the wizard looks for EF models in the SAME project as the one where you're adding the template item. Please make sure that the selected file in the Solution Explorer is within the project where you EF model lives.


Jul 23, 2010 at 3:46 PM

Found the cause of the empty Model Chooser.

It would happen only if no documents were opened in the VS editor.

It is now committed to repo.

Jul 23, 2010 at 4:43 PM

Specifically .edmx documents.

Jul 23, 2010 at 7:59 PM


Can you build the VSIX yourself ? You can use this revised one if you want to:

Please be aware that this is my development version, so things might be different when we actually release a new BETA.